Internetルーティング講座

1nobody

お料理好きのnobodyです。

ルーティング、特に大規模IGPだとか、BGPの綱引きに興味のある人向け

のスレです。

まずは、以下の資料を読んで勉強してね。

□大規模ネットワークにおける経路制御技術

hhttp://www.nic.ad.jp/jp/materials/iw/1999/proceedings/i/C18.lzh

□BGP4 -プロトコルの概要と運用-

hhttp://www.nic.ad.jp/iw98/presentations/C14.pdf

26SOI

>>1

hhttp://www.soi.wide.ad.jp/

にそれのビデオあるよー

IW2000も友近さん前村さんで

「大規模ネットワークにおける経路制御設計」というタイトルです。

48nobody(1)

>47

OSPFって、よく考えるとリンクステートですよね。ルータ間の接続状況を

交換していると(くわしくは>>1の資料を参照してね)。

で、コネクトな情報をフィルタするって、どうやればいいんでしょうか?

そのリンクステートを送信しないなら、ルータ間の接続がないのと同じでは

ないでしょうか?

#くわしくは調べてないよ、OSPFのoutフィルタは効かないと思い込んで

#いたから….

dist-listのinは、「データベースとして持つが、ルーティングテーブル

には載せない」という動作と思われ。実験してみればよくわかると思う。

汚いネットワークをどーにかせなあかんのは往々にしてあることです。あまり

に汚いネットワークにキレて、境界間をBGPで繋ごうかと思ったこともありま

したなあ….

60nobody

なんか落ちちゃってますねえ。

簡単な質問でも気軽に質問してもらってよいのですが、どうも最初に>1で出来

のいい資料を出しちゃったのがまずかったのかなあ。いかにも「タコは勉強し

てから来い」って言ってるようで。

>1を書いたちょっと後に、某所であの資料を印刷している光景に出くわした。

まさかココ見てたんじゃ….

#しかし、あのプレゼンの内容を売り物の本で読もうと思うと、学生なんか確実に破産ですね

160anonymous@KD114017184107.ppp-bb.dion.ne.jp2009-01-16 00:29:58

>1 の資料、わかりやすくて実用的ですげぇ

使わせてもらうわ thx

4名無しさん@1周年

network やっている人はこのスレで勉強するのが重要。

社内LAN管理者もBGPについてはきっちりおさえておくべき。

理解して、人に説明できるようにすること。

6nobody

>4

マルチホームやるときにBGPの知識がいるようになるかもしれへんからねえ。

7ななし

>>6

をいをい、マルチホームしているところにいちいち AS number 割り振っていら

れないって。普通は Linux の iproute2 で十分でしょ。

10nobody

>7

PAじゃなくて、PIなアドレス持っている所で、独自AS取る場合にはBGP必須

だけど、プライベートASでマルチホームやっている所もありますよ。

8Name Not Found

地方のしょぼい中小企業だとYAMAHA様々だよ。

hhttp://www.rtpro.yamaha.co.jp/RT/docs/multi-homing.html

13喜ぶ名無し

>>8

そのとーりです…イタタ

Ciscoなんであんなに高いんだよぉ

LinuxBOX使って何とかしたいのが現状

ってなことで…勉強しなければ

あ。今日は休日じゃないかぁぁぁぁ

11

昨日、CiscoでOSPFの設定しててはまったんだけど、

VLSMのスタティック経路を再配布するときって、

reditri sta

の後に”subnet”をつけなきゃいけないことを初めて知った。

VLSMは社内では初めて使ったんだけど、

これってもしかして常識だったの?

ciscoのリファレンスにはそんなこと書いて無かったよ。

1時間悩んだ。

15nobody

>E1かE2か

E1とは?

16nobody(1)

>15

1の「大規模ネットワーク経路制御技術」は読んでいただけましたでしょうか?

25pに解説があります。

24

罵倒するぐらいなら教えなきゃいい。

教えるんなら気持ちよく惜しげもなく教えればいい。

結局「教えてやった」っていう充足感を味わいたいだけ。

しょせんはマスターベーション。

感謝する必要なんかねーよ。

25a

>>24

惜しげも無く教えたら、そいつはしつこく質問してきやがるでしょ

>>1が最初に、ここは啓蒙するスレだっていってるじゃん

>>12はとりあえず説教して、資料だけ教えてやる、後は自分で調べれ

っていうスタンスを示したんだろ

>>1の言ってる趣旨の通りにやっただけ

それが気に入らないんだったら、別のスレ逝け

35nanasisan

IX っていうぐらいだから、複数の AS が接続していないと

だめでしょう。JPIX から線を引いてくるだけじゃなくて、

プロバイダからも線を引いてくる。

んで、BGP をしゃべれる router (PC UNIX + Zebra でも OK)

をつないで、AS number を振って…とかいう感じになる。

39nobody(1)

>35

単なるL2スイッチじゃだめなの?

IXって、あくまでもISP同士がピアを張る所だって認識だけど….

36sage

厨房な質問で申し訳ないのですが、一つお願いします。

CiscoルータでOSPFのdistribute-listを書いて、

ConectedなRouteをフィルタするにはどうすればいいのでしょうか。

——————————————

Conected 172.16.100.254/24

Conected 192.168.100.254/24

Static 10.100.100.0/24 via 172.16.100.1

!

router ospf 1

redistribute static

network 172.16.100.0 0.0.0.255 area 0.0.0.0

network 192.168.100.0 0.0.0.255 area 0.0.0.0

distribute-list 10 out

!

access-list 10 deny 172.16.100.0 0.0.0.255

access-list 10 permit any

——————————————-

こんな感じに設定したのですが、172.16.100.0/24の経路を投げてしまいます。

フィルタをインターフェイス指定にすればよいかと思ったのですが、

インターフェイスを指定すると、

%interface not allowed with OUT for OSPF

といわれます。

どなたか、ヒントをいただけないでしょうか?

38nobody(1)

>36

OSPF出し側のdistribute-listって効いたんだっけ?

なんか制限あったような。

45(・∀・)

>>36

172.16.100.0 のRoutingをくらいたくないRouterのinでフィルタすれば(・∀・) イイ!!

>>38の云うとおりOSPFはdistribute-list outで制限デキナカターヨ

43名指しさん

>>35

>>39

のいうとおり L2 SWだけでOK!

JPIXから線を引かなくてもTransit買わなくてもBGP知らなくてもルータなくても

IXはできます。

4437

L2スイッチって…おいくらなのでしょうか?ボソッ

46nanasi

>>43

なるほど。単なる線の集積所としての IX だとそうですね。

>>44

そこいらに転がっている ehternet のスイッチングハブでも

立派な L2 スイッチですから、¥3000ぐらいからあるかな?

VLAN 切れるような高級品でも¥2万ぐらい?

4936

>>48

いろいろありがとうございます

いい勉強にはなりましたが、

Ciscoマルチベンダーな世界でどっぷりEIGRPにつかりたい今日この頃です

5349

>>48

できました!

192.168.と172.16.でそれぞれ別のOSPFプロセスを動かしたらできました。

こんな感じです

———————————————

!

router ospf 1

netwaork 192.168.0.0 0.0.255.255 area 0.0.0.0

redistribute ospf 2

redistribute static subnet

distribute-list 10 out ospf 2

distribute-list 10 out static

!

router ospf 2

network 172.16.0.0 0.0.255.255 area 0.0.0.0

redistribute pspf 1

redistribute static subnet

!

access-list 10 deny 172.16.100.0 0.0.0.255

access-list 10 permit any

59?

>>57

話が理解できてないと思われ

connectしてる経路のフィルタの話だろ?

rouetmap以前にフィルタ自体がが効いてないのではないかと、、、

62

>>60

あんた自意識過剰だね。

69anonymous@ eAc1Aaa137.tky.mesh.ad.jp

突然書き込みしてすいません。

いつも思うのですが、JPIXのMLに出ている「出国のピーター」さんっって

何者なのですか?あの、独特の日本語がまーべらすです。

某ISP、やたらPrefixの小さい経路を流さないで下さい。(フィルタで対処してるけど)

70名無しさん

>>69

おもしろい方です。あやむら氏と仲がよろしいようで。

某所のchapter11騒ぎで去ってしまわれないかが怖いです…

71774

>>69,70

ピーターさんもう辞めてるよ。JPIXのMLにご本人が出してたでしょ。

ところで、69さん、どれくらいの大きさのprefix-filter書いてます?

7569

>>70,71

ありがとうございます。お礼がおそくなってすんません。

あの心あたたまる日本語を読むことはもうできないのですね、、、、

72nobody

Janog8でIIJの近藤さんいわく、なんか/31があったらしいね。

/31は実験だろうか?

7369

>>71

うちは/25まで食べます。

>>72

/31ですか?まじでぇ?!?!?!

最近、/24のアドレスが/28で16に分割されて広告されているところ

があるんだけど、なにかの実験かな?

78名無しさん

>>73,74

IXの受け入れ経路だけでなく、

トランジット側も同じなんですか?

>>75

NRIに結局行かれたんでしたっけ。

77fshiansan

CiscoPressのインターネットルーティングアーキテクチャも良い

2版がでてたので思わず買ってしまった。

思ったより親切なつくりで初心者でもいける。

(ネットワーク初心者じゃなくてBGP初心者ね)

良書だ

81

ハッカーの次なる標的はルータ

hhttp://www.atmarkit.co.jp/news/200112/27/router.html

89 

>>81

ご飯中失礼するが、次なるじゃなくて最初のだとオモタ。

いや、オマエに言ってるんじゃなく書いた奴にナ。

Ciscoはいいルーターではないと思う人より(ぷ

91balance

OSPFということで、ここが内容的に近いスレですかね?(無理矢理ですが)

今頃知ったんですが、ダイクストラ教授が8月6日に亡くなったんですね。

ご冥福をお祈りします。

92nobody

>91

ダイクストラアルゴリズムには、いろんなところでお世話になってますね

98anonymous@ PPPa72.e6.eacc.dti.ne.jp

CiscoルータでIS-ISを動かすには、IOSのどのバージョンから稼動できるんでしょうか。

99nobody

>98

IS-IS自体は相当前のバージョンからサポートしてるけど、

IS-ISのIPv6対応を言ってます?それともMPLS-TE用IS-ISですか?

100anonymous@ PPPa44.e6.eacc.dti.ne.jp

>99

IPv6は考えておりません。普通の12.0(6)とかでも、router isis とか入れても

反応がないのですが。show isis routeとかもshow isis databaseとか

show clns… とかを試してみたいです。(早速のお返事ありがとうございます)

116nobody

>BGPで受けた経路ををOSPFにredistして、

うーん。経路数が十分少なければこのアプローチも可能だと思うけど、

大規模な環境だと普通はiBGPでlocal prefかなんかで振り分けませんか?

iBGP multi-pathってのもありだと思うけど。

118__

>>116

iBGPでLocal_Prefで分散しましたっけ?

iBGP MultiPathだと同一収容ルータからのトラフィックは

分散しない気がするのですが。

119?

>>118

Border2台からOSPFに等価でDefaultを流して

Border間でiBGPを張るんじゃダメですか?

120115

>>119

特定のpeerに対してのロードバランスなんですよ。

なのでBGP->OSPFのredistかなぁと。

121nobody

>118

ああ、想定している状況が違うね。あとでゆっくり書きます

>120

その条件、結構難しいかも。特定のピアからのをredistするのは簡単だけど、

相手が事故って大量の経路を通知してきたらこっちのIGPが死んじゃうから、

prefix-filterも必要かも。max-prefixのリミットって今のIOSはちゃんと動

くんだっけ?

122眠たい質問者

最近ルーティングのことを知り始めたのですが、下記の環境でルーティングをうまいこと

設定すればプロキシはいらなくなりますか?

いらなくなるのなら勉強してやってみるつもりです。

モデム(ルータ内蔵)

|

Win2kServerPC(プロキシ稼働中、NIC2枚差し)

|

LAN内の各クライアントPC

124sage

>>122-123

Win2Kがルータとして動いていると仮定して、ルータ内蔵モデムが

クライアントPCのあるネットワークをどうやって知ることが出来るのか

(ルーティングテーブルを持たせられるか)を考えてみましょう。

判らなかったら、初級ネット板逝きましょう。

125122

>>124

Win2kはルータとしては動いてないです。

ルーティングとリモートアクセスってのをいじればできるのかな、と思ったけど

何が書いてあるのかさっぱりだったので結局止めたままです。

ルーティングを適切に設定すれば「クライアントPCからプロキシを経由しないでインターネットに出られる」ということですよね?

もう少し情報集めて勉強してみます。

126?

懐かしいスレが上がっている、、、

>>125

クライアントを直接通信させるならモデムをPCのLANおけばいいだけでは

セキュリティ的な用件でプロキシにしてるんじゃないんですか?

何がやりたいのかよくわからないです

あと、ここは一応”インターネットルーティング”講座なんだけどね

nobody氏もここ半年ぐらい見てない気がするが

134__

>>133

さんくす

見つかりました。

インターネットウィークの資料は他にも面白そうな物が一杯ですね。

しっかり読ませてもらいます。

135anonymous@ eaoska196048.adsl.ppp.infoweb.ne.jp2005-05-16 16:32:56

すいませんが誰か教えてください。

1.あるIPデータグラムを転送するにあたって,ルーティング(L3)によって

処理するかアドレス解決(L2)によって処理するかは何を基準として

決定されるのですか?

2.ルーティングテーブルの持つエントリ数が非常に大きくなった場合,

どのような問題が生ずると考えられるのですか?

2に関しては通信速度が遅くなる、レスポンス低下でいいのかなと

思うのですが、1は調べましたが分からないです。

136syscow2005-05-16 23:42:19

>>135

どんなIPデータグラムも、まずL3の経路表を参照して、それからL2で

アドレス解決して転送するよ。ルータならね。

137anonymous2005-05-17 01:28:51

>>136

普通はそうして経路表を参照した後、結果をキャッシュ(転送表)に入れとき、続けて

同じアドレスに送られるパケットが着たらそのキャッシュを参照してnext hopに送る。

この表をさらにハードに送って高速化なんかもされる。

>>135

2. の他の問題はメモリを食うことと、経路情報の変動に対処するのに要する負荷の増大。

1421352005-05-17 13:03:34

>>136,137

ありがとうございます!!助かりました

1381362005-05-17 07:42:08

>>137

ふむ、そうした高速化って普通というほど普通じゃないと思うんだけど

どこの実装のこと?

古きゆかしきBSD由来の実装はL3の経路表の中にL2の情報を入れちゃってるし、

CiscoのCEFは結局L3の経路表とL2のアドレス解決情報を分離したまま高速化

しただけだし、こいつらは当てはまらないよね。いわゆる forwarding cache

は結局L3のキャッシュだし。

139anonymous2005-05-17 09:36:47

>>138

あれ、CiscoのFIBってL2は含まないのですか?それは知りませんでした。 そうだと

思い切ってた。 自分が某メーカでいじってた実装ではL2も含めてキャッシュしてたもんで

そういうもんだと思ってました。

140anonymous2005-05-17 10:57:46

>>139

138が無知なだけなんだけど、誤解が広がるのは良くないので

hhttp://www.cisco.com/japanese/warp/public/3/jp/product/hs/ios/cef_wp.shtml

1411382005-05-17 11:09:24

>>140

FIB (L3) と Adjacency Table (L2)は明確に分離されているように見えるが…

1441392005-05-18 04:58:31

>>141

>>140さんのリンク先の図では2つのテーブルが別にありますが、それが←→という線で

繋がってますよね。 どちらのテーブルもIPアドレスで参照されるので、FIBが参照された後、

その次に参照したL2の結果をFIBのエントリーにキャッシュすると言うのはごく真っ当で

単純な最適化かと思います。 まあこれが実際に1つの表として実装されるかポインタで

参照される2つの表かというのは似たようなものかと。

143_2005-05-17 16:46:54

>>135

素人が作ったようなへたな問題なんで問題自体が正確じゃないが、

気持ちだけを汲み取ってやると、問題は

ルーティング処理 → 宛先が異なるネットワークアドレスの場合

ARP解決 → 宛先が同一ネットワークアドレスの場合

という部分の処理の違いを問いたかったんじゃないかな。

あくまで出題者の気持ちを汲み取って深読みしただけだから

本当かどうかはわからないけどな。

149 2005-11-02 20:54:12

>>148

「インターネットプロトコル(TCP/IP)のプロパティ」 のところにデフォルトゲートウェイ書いてない?

そこがカラなら大丈夫だと思うんだけど。

2 枚 NIC 挿しててもデフォルトゲートウェイは 1 つしか使われないから Metric 増やして対処してもいいかもね。

シェアする

  • このエントリーをはてなブックマークに追加

フォローする